Can't Push Site To Heorku

OK so i looked around google and stack overflow because of this below error.

ERROR: Could not find a version that satisfies the requirement pywin32==300

I removed any win packages from the requirements files as Heroku is Linux and does not play well with windows packages.

But here is the problem, as soon as i run the Command again, it still installs those packages from the .txt file, even tough i have saved the file with the packages names removed… So it Fails to in the end with the Above error…

My Specs:

Python 3.9.1

Windows 8.1 (64 bit, x64 - based processor)

Django == 3.2

Heroku== heroku/7.53.0 win32-x64 node-v12.21.0

Using MINGW64 to pass the Commands:

$ git push heroku HEAD:master

Thanks :slight_smile:

It seems similar to this issue on SO.

Can you post your heroku logs and your requirements.txt?
Please, use a pasting service like pastebin to post the logs! Thanks.

hi i just solved it yesterday, by creating a virtual environment and doing stuff there, so my requirements file packages became a whole lot less. and it worked :slight_smile:

but now i have another problem with Amazon S3 actually. can you please see this thread and help out :slight_smile: