# Django just stops working

**URL:** <https://forum.djangoproject.com/t/django-just-stops-working/20128>\
**Category:** Deployment\
**Created:** [April 7, 2023, 6:21pm UTC](https://forum.djangoproject.com/t/django-just-stops-working/20128 "2023-04-07T18:21:35Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![fornakter](https://sea2.discourse-cdn.com/flex026/user_avatar/forum.djangoproject.com/fornakter/32/12813_2.png) [@fornakter](https://forum.djangoproject.com/u/fornakter)\
**Post date:** [April 7, 2023, 6:21pm UTC](https://forum.djangoproject.com/t/django-just-stops-working/20128/1 "2023-04-07T18:21:35Z")

</div>

Hi.  
I have a server Ubuntu, with Nginx and Gunicorn.  
Everything works fine, but today ISP change my IP. I change it on nginx/sites-available/myproject, restart gunicorn, nginx, server, whole computer and still dosent work.  
Its just start html site from /etc/www/html.  
Log error from nginx /var/log/nginx/error its clear.  
I dont know how to find an error.  
systemclt status gunicorn or nginx, nginx -t give me no error.  
Only when i type

```auto
sudo journalctl -u gunicorn.socket

```

it give mi something like:

```auto
gunicorn.socket: Deactivated successyfuly.
Closet gunicorn socket
--- Bot [looks like random numbers] ---
Listening on gunicorn socket

```

And it repeat.

Help ☹

---

<div class="post-metadata">

**Author:** ![KenWhitesell](https://sea2.discourse-cdn.com/flex026/user_avatar/forum.djangoproject.com/kenwhitesell/32/280_2.png) [@KenWhitesell](https://forum.djangoproject.com/u/KenWhitesell)\
**Post date:** [April 8, 2023, 2:26pm UTC](https://forum.djangoproject.com/t/django-just-stops-working/20128/2 "2023-04-08T14:26:45Z")

</div>

You’re going to need to provide more details and be more specific with the information you’re providing.

What do you mean by “just stops working”?

In addition to looking at your nginx error log, you’ll also want to check the access log and syslog. The relevent portions of syslog are likely to be your best starting point.

> [@fornakter](#):
>
> but today ISP change my IP.

Are you accessing your site by IP address or by DNS name? If by DNS, did you change your DNS entry to match the new IP address?

If you’re looking for more help here, you may end up needing to post all the relevent configuration files (nginx, gunicorn).

---

<div class="post-metadata">

**Author:** ![fornakter](https://sea2.discourse-cdn.com/flex026/user_avatar/forum.djangoproject.com/fornakter/32/12813_2.png) [@fornakter](https://forum.djangoproject.com/u/fornakter)\
**Post date:** [April 8, 2023, 5:27pm UTC](https://forum.djangoproject.com/t/django-just-stops-working/20128/3 "2023-04-08T17:27:14Z")

</div>

I understand You, but i only change i IP on nginx/sites-enable/myproject and it still dosent work.  
Thats why i have problem with that.  
I can connect to server with IP but without Django.  
Now nothing works. Status nginx its ‘works’ but still cant connect to server.  
Give me some time, i upload settings.

---

<div class="post-metadata">

**Author:** ![fornakter](https://sea2.discourse-cdn.com/flex026/user_avatar/forum.djangoproject.com/fornakter/32/12813_2.png) [@fornakter](https://forum.djangoproject.com/u/fornakter)\
**Post date:** [April 9, 2023, 7:55am UTC](https://forum.djangoproject.com/t/django-just-stops-working/20128/4 "2023-04-09T07:55:24Z")

</div>

Yea, i found error.  
When router was reboot, server has new local IP.  
So i just need to change IP on firewall (forward) and it works. Theres no errors from server.  
Sory about that 🙂  
Thanks for try to help me 🙂
