A library issue more so than a Django problem. Images with Pillow, library "not installed" however, it is installed.

I am using Windows 10, this “Pillow” image library seems to be tested more often by the developers on linux distributions.

I am trying to make an upload image field in the database with the “ImageField” model.

I have Pillow 9.2.0 installed.

When I try to make migrations I get this message:

Cannot use ImageField because Pillow is not installed.
HINT: Get Pillow at Pillow · PyPI or run command “python -m pip install Pillow”.

How very frustrating. I have looked at their platform compatibility charts on their website, but I don’t want to waste hours and hours trying to test different python versions just to get passed this error.

So my main question is this:

Have you managed to get the “ImageField” model working while you are on a Windows 10 machine?
If so - Which version of Pillow are you using. And which version of python are you using?

What they claim to have tested on Win 10:

Windows 10/Cygwin 3.3

Python versions 3.6, 3.7, 3.8, 3.9

Pillow 8.4.0


I have tried Pillow 8.4.0 and Python 3.9.13…not working.

I have never tried. We don’t deploy Django sites on Windows.

Unless you’re running everything in Django in Cygwin, using a Cygwin-based version of Pillow isn’t likely going to do you any good.

That same compatibility chart shows Python 3.7 / Pillow 7.1.0 as your only option. (This is not to say that you couldn’t compile Pillow from source yourself for newer versions of each and test them - but the chart doesn’t show any information for newer combinations.)

A web search for Pillow Windows 10 Python 3.10 shows some videos for how to do this - one or more of those may be of help.

Thanks, I can’t seem to fork any version of Pillow older than 8.4.0 anymore.
But I will try Python 3.7 or 3.8 later because it was a bit daring of me to assume 3.9.13 would work.