Channels+Daphne do not close ws connections on azure.

Hi all!
I spotted strange behaviour when I host my channels app using daphne on Azure Kubernetes Service. Logs indicates that websocket connections are opened as usual, but after I close tab with WS client it do not disconnect the client.

When I run the same setup again on localhost it seems to be just fine
so in general this logs appears on both envs - - [20/Jun/2024:12:25:20] "WSCONNECTING /ws/" - - - - [20/Jun/2024:12:25:20] "WSCONNECT /ws/" - -

but im missing this logs on prod: - - [20/Jun/2024:12:25:25] "WSDISCONNECT /ws/" - -

Moreover i receive strange timeout errors such as

INFO 2024-06-20 12:26:21,548 daphne.server Timing out client: IPv4Address(type='TCP', host='', port=58993)

exactly after one minute since connection. I don’t know what might cause that really, and what is this client at all.

I’m kinda aware that this issue might be not caused directly by channels/dahpne, yet I ran out of ideas how to debug it further and what could cause it.

Do you guys know any methods or ideas how can I debug it even further?

After further debugging this issue was just a logging issue. Logs appear but later on. It was coupled with other issue that users of azure might encounter during managed redis cache usage (azure cache for redis). I described solution to that here: