Django 4 / pytest-django live_server for tests is claiming https?

Hi all,

I am using Django 4, with pytest and pytest-django, and I’m trying to get Selenium working because a significant source of trouble for us has been the final rendered layout in the browser obscuring things and making buttons unclickable when the user makes the page just a bit narrower than the UI builder expected.

platform win32 -- Python 3.9.12, pytest-6.2.4, py-1.10.0, pluggy-0.13.1
django: settings: mysite6.settings_components.development (from ini)
rootdir: C:\Users\atcra\Coding\KEN_development, configfile: pytest.ini
plugins: Faker-9.9.0, django-4.4.0

The problem I’m running into is that the live_server is claiming SSL, but it isn’t satisfying the browsers (tried Chrome and Firefox) and so they open and wait at the page that warns you ‘we can’t verify this page, click here, here and here’. I’ve tried some of the ‘ignore-bad SSL’ service options but no luck, which probably makes sense as I haven’t set up any SSL on the developer settings - its completely missing, not just self-signed.

live_server = <LiveServer listening at https://localhost:58806> # Note the "s"

Following the example in the [LiveServerTestCase docs], this problem is not coming up.(Testing tools | Django documentation | Django)

Server URL:  "http://localhost:59152"

Looking through the source didn’t clear up the mystery - it seems to straightforwardly wrap the django “live_server” from django.tests, but it results in a https url.

I’ve found pointers to the django_extensions runserver_plus which can do locally signed SSL, but would need guidance on how to ask the live_server to launch a different server. While I guess ultimately I aspire to be doing a CI/CD sort of development where the dev & test env is identical to production. Thanks

I don’t know what the basis of this problem was but I cut the “s” out of the live_server.url string and got around the issue that way.