Need help on Django tutorial Part 2

Hello, my polls app is not showing up on my admin page. Here’s the tutorial for reference. Writing your first Django app, part 2 | Django documentation | Django

I feel like I did everything exactly as stated and couldn’t find a similar issue when searching. If anyone could offer help I would be very grateful. I found the issue could be in the file under installed apps but I think mine looks fine.

my file:


And then polls/

from django.contrib import admin

from .models import Question

The admin page shows nothing and I am stumped.

I tried giving the superuser permissions too an nothing changed.

Thank you for the help.

Did you stop and restart runserver after making these changes?

What URL are you going to?

That’s not the complete page - or if it is, then you’ve got some cached css that is messing up the display.

Go to the root url for the admin (usually admin/) and hit shift-refresh (or shift-F5). Post another image, but this time of the complete browser window.

Thank you for replying.

Following the tutorial I did the ''python runserver ‘’ after creating the superuser. The tutorial says If the server is not running start it like so:
$ python runserver

I received the response: ‘Error: That port is already in use.’

Here is the full screenshot with the URL

That means you already have the server running. You need to stop the running instance before restarting it.

Hmm… I’ve tried control C and then when I try the runserver command again it gives the same error.

Is there a preferred way to stop running it?

Yes, control-C should stop the process and return you to the command prompt.

What happens in your command prompt window when you hit control-c?

Also it might help to describe your development environment a bit. What operating system are you using? What versions of Python and Django? Are you using a virtual environment?

(django3) 00:54 ~/django_projects/mysite (main)$ ^C
(django3) 00:56 ~/django_projects/mysite (main)$ 
(django3) 00:56 ~/django_projects/mysite (main)$ python runserver
Watching for file changes with StatReloader
Performing system checks...
System check identified no issues (0 silenced).
August 31, 2022 - 00:56:13
Django version 3.2.5, using settings 'mysite.settings'
Starting development server at
Quit the server with CONTROL-C.
Error: That port is already in use.
(django3) 00:56 ~/django_projects/mysite (main)$ ^C

Control C just does ‘^C’. I tried looking up alternative kill commands as well but each time I runserver after I get the same error.

I am using python anywhere which is Linux but I am on a PC. I am using a virtual environment, Django version 3.2.5, python 3.8

Ok, python anywhere is a cloud-based service, isn’t it? In which case running runserver locally is meaningless.

You need to restart your instance of runserver in python anywhere.

Unfortunately, I don’t use it and don’t know anything about it. Hopefully someone else here may be able to help you.

Yes, it’s cloudbased. Thank you for your help. I’ll update if I figure it out


Thank you, Ken, for pointing out this was an issue with PythonAnywhere, as I was hyper-focused on looking for a typo in my code.

I simply needed to reload the changes from the webapps page, not runserver.

If anyone else ever has this issue, the answer is simple and in this document: