setting SECURE_HSTS_SECONDS as 0 causing ERR_SSL_PROTOCOL_ERROR in browser.

I accidentally set the SECURE_HSTS_SECONDS value to a non-zero value on my local development server. The Chrome browser expectedly returned an ERR_SSL_PROTOCOL_ERROR. I set the SECURE_HSTS_SECONDS value to zero, cleared the cache, and reset the HSTS policies by visiting chrome://net-internals/#hsts. It was still returning the same error.

I then removed the SECURE_HSTS_SECONDS from the settings file and reset everything just as I did before, and the error was gone. When I add the SECURE_HSTS_SECONDS to the settings file again, regardless of the value being zero or non-zero, the issue resurfaces. Did I misunderstand how it all works?

Is your local server being accessed on the browser via HTTPS? Because normally you access the local server via HTTP. And this setting should only be defined on a HTTPS environment.

Yes I understand that. But I accidentally set those variables in my local environment. But I did remove it as I have mentioned but the issue persists.