Django CacheDatabase

I have a cache that is configured to use my database backend, which is my SQL. When I store the cache and call it, it does not call the most recent cache value it calls the one that was there prior. How do I tell Django to call the most recent one and not the one prior to that?

Example. Cache at 1pm is 1234 cache at 1:02pm is 5678. Django is calling the 1pm cache and not the most recent 1:02pm cache

We’re probably going to need to see the specific code involved - how you’re setting and retrieving cache data, along with more details as to what you’re looking that that is giving you this information.

This is what I have

This is my settings file

@KenWhitesell i am using Django DatabaseCache. Saving it with Cache.add retrieving it with cache.get

Please do not post images of code. Copy/paste the code into the body of your message, enclosed between lines of three backtick - ` characters. This means you’ll have a line of ```, then your code, then another separate line of ```.