Django debug stuck at "Performing system checks..."

Hi, When I start debug my django-rest api, debugging starts and this output shows up:

Watching for file changes with StatReloader
Performing system checks...

launch.json file:

    // Use IntelliSense to learn about possible attributes.
    // Hover to view descriptions of existing attributes.
    // For more information, visit:
    "version": "0.2.0",
    "configurations": [
            "name": "Python Debugger: Django",
            "type": "debugpy",
            "request": "launch",
            "program": "${workspaceFolder}/",
            "args": [
            "django": true

As debug server not started I can’t access my api endpoint.

Did you recently update some code or reinstall an older version or make some other environmental change? (Upgrade or downgrade Python, change virtual environment, anything?)

Not actually I haven’t changed anything. This is the case when I am using pycharm as well.

What happens if you try running it directly from the command line?

There have been a couple instances reported here of similar symptoms. While there hasn’t ever been one specific cause identified, two things have been recommended to try:

  • Delete all .pyc files in the project.
  • Run the Django extensions command clear_cache.

When I run python runserver it works fine. This case happens while only debugging. Thank you for your advice. I will try and let you know.

Unfortunately, nothing you said worked.

Unfortunately, it didn’t work.

My next suggestion then would be to create a new virtual environment with a fresh install of all the packages, and use it instead of your existing venv to see if that helps.