Help request : 5.0 hangs in production


I am sorry in advance that this initial post is going to be a bit vague. I am looking for help diagnosing the issue ang gathering more data.

I have a Django app that provides an API built with Django Ninja. The request handlers are mostly async and use the asynchronous ORM API. The DB is Postgres and i’m using Pgbouncer as well. The server is Uvicorn + nginx (as a Kubernetes ingress).

With Django 4.2 everything works well, both local and production
With Django 5.0, things work locally but in production, the server “hangs” after a few successful requests and then never responds. CPU usage is low, it just does stops responding to requests.

I tried launching Uvicorn locally and it works just fine, even after many requests and several minutes of uptime.

How can I diagnose further / reproduce the issue locally ? Where to look at ? Can PGBouncer be the cause ?

Thank you very much for the help !

Hi @GTorreil.

Can you try running the stable/5.0.x branch now please?

There’s a ticket #35059, due for release in Django 5.0.2 (tomorrow) that may be related to this.

1 Like

Hello @carltongibson ,

I tried it and it’s working ! So, I assume this was my issue. I did search for tickets about this but obviously my search terms were inaccurate, so I hope this thread helps people find it.

Anyways thanks a lot !

Great. Thanks for confirming. It’s due for release tomorrow.

//cc @felixxm @nessita fyi.

1 Like