Installation error.

I know it’s not relevant for this group, but again have the hope for getting my issue resolved by @KenWhitesell .
Whenever I am trying to install anything, I am getting this wired error, even couldn’t upgrade the pip. Anyone could help me with that
Tried to share the errors via Pastebin:
Even I tried to install on my Ubuntu image( wsl ) and got the same error. I am getting the error from the last night.

“I ain’t the only one here” :wink: There are lots of helpful people floating around.

But, since I do happen to be online at the moment, I took a look.

The error itself is quite clear - you’re getting a timeout error trying to do the pip install. And, looking at the speeds you’re reporting, you’re trying to do this through a fairly slow connection. (Those are dial-up type speeds.)

When I’m in this type of situation (and it does happen from time to time), I have better luck downloading the wheels first - pip wheel fastapi, which will put a copy of the wheel in my current directory, followed by pip install fastapi-<whatever the full filename happens to be>.whl

If that doesn’t work, then I’d try going to directly, searching for the package and manually downloading the files from there.

1 Like

It should also be noted pip are trying to fight off a bad actor who is bypassing their CDN, so may be experiencing some issues - see Dustin Ingram on Twitter:


Yeah @KenWhitesell you’re right, it was my Internet connection issue. I just saw some same issues on Github so I thought maybe I am having the same kinda issue. Finally, it’s working now. Thanks, @KenWhitesell and @adamchainz