Django launching

Hi everyone. I just recently learned basics of Python and reached theme about Django. According instructions in book with which I’ve learning I sticked at beginning. First I downloaded library of django from command line. Then created especial folder for it in desktop. Then in this folder i created environment. After I created project with command “django-admin startproject myfirst” I tried to check if it works how needed and gave command “python runserver”. There after typical message I received error. Does anyone say, how I can solve this? Text of error message:After typical message:

Exception in thread django-main-thread:
Traceback (most recent call last):
File: “C:\Program Files\Python38-32\lib\”, line 932, in _bootstrap_inner
File: “C:\Program Files\Python38-32\lib\”, line 870, in run self. _target(*self._args,**self._kwargs)
File: “C:\Program Files\Python38-32\lib\site-packages\django\utils\”, line 53 in wrapper
fn(*args, **kwargs)
File: “C:\Program Files\Python38-32\lib\site-packages\django\core\management\commands\”, line 139, in inner_run
run(self.addr, int(self.port), handler,
File: “C:\Program Files\Python38-32\lib\site-packages\django\core\servers\”, line 206, in run
httpd = httpd_cls(server_address, WSGIRequestHandler, ipv6=ipv6)
File: “C:\Program Files\Python38-32\lib\site-packages\django\core\servers\”, line 67, in init
super().init(*args, **kwargs)
File: “C:\Program Files\Python38-32\lib\”, line 452, in init
File: “C:\Program Files\Python38-32\lib\wsgiref\”, line 50, in server_bind
File: “C:\Program Files\Python38-32\lib\http\”, line 140, in server_bind
self server_name = socket.getfqdn(host)
File: “C:\Program Files\Python38-32\lib\”, line 756 in getfqdn
hostname, aliases, ipaddrs = gethostbyaddr(name)
UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xca in position 0: invalid continuation byte>

I looked up solution everywhere, but can’t find. Thanks for help.

Looks like your computer’s name is not in the right encoding.

Not sure if it’s the only way but, on Windows 10 you can tick a “Use Unicode UTF-8 for worldwide language support”, box in “Region & Language” - “Administrative” - “Change system locale” - “Region Settings”.

Reboot, and hopefully everything uses UTF-8 ≈everywhere.

Unfortunately, my Windows is 7th, so no such option. But I tried to do it changing code page from command line with command “chcp 65001” but unsuccessful, same error