Hard disk path appeared in the admin url, how to remove it?

Hi,I use Django 3.1, and i get a trouble. who can tell me how to do. thanks.
My problem is my site path in linux Hard disk appeared in the admin url, like this:
http : \\www。xxx。com/data/pysites/mysite.com/mysite/admin/
'/data/pysites/mysite.com/mysite/ ’ is my linux path,
it appeared in the admin url,
I hope it is only ‘http://www.xxx.com/admin/’,
how can i remove it?

in vews.py, i print request.path is:
i think the right path shuold be /play/ed160af7-5c98-4868-a679-2e86803e67d2/

How are you running Django? Are you using runserver, runserver_plus, gunicorn, uwsgi, etc?
Are you running Django behind a web server such as apache or nginx?
Can you provide more details about your runtime environment?

thank you very much.

I use supervisord + daphne + asgi + nginx.

daphne run command:
command=/data/pysites/xxx.com/venv/bin/daphne -p 60017 --root-path=/data/pysites/xxx.com/mysite mysite.asgi:application --access-log /data/pysites/xxx.com/daphne.log --proxy-headers

and nginx proxy_pass like this

	location ~ ^/ws/ {
		proxy_pass http://daphne;		
		proxy_http_version 1.1;
		proxy_set_header Host $proxy_host;
		proxy_set_header Real-Host $host;
		proxy_set_header Upgrade $http_upgrade;
		proxy_set_header Connection "upgrade";
		proxy_set_header X-Real-IP $remote_addr;
		proxy_set_header REMOTE_ADDR $remote_addr;
		proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;	
		proxy_read_timeout 3600s;		
	location ~ ^(?!(/static/|/upload/)) {		
	  proxy_set_header Host $http_host;
	  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
	  proxy_set_header X-Forwarded-Proto $scheme;
	  proxy_set_header X-Real-IP $remote_addr;
	  proxy_set_header REMOTE_ADDR $remote_addr;
	  proxy_redirect off;
	  proxy_buffering off;
	  proxy_pass http://daphne;

You’re causing it by using the root-path parameter in your run command.

See the Daphne docs for Root Path, and the referenced docs for WSGI SCRIPT_NAME.

Oh! You are really a master.
I changed the start command, remove --root-path parameter , and It’s working fine.
thank you very much .

## command=/data/pysites/xxx.com/venv/bin/daphne -p 60017 mysite.asgi:application --access-log /data/pysites/xxx.com/daphne.log --proxy-headers