SQLite 3.9.0 or later is required (found 3.7.17)

I am deploying the Django application AWS Linux server. I am getting error

  File "/usr/local/lib/python3.7/site-packages/django/db/backends/sqlite3/base.py", line 69, in check_sqlite_version
    'SQLite 3.9.0 or later is required (found %s).' % Database.sqlite_version
django.core.exceptions.ImproperlyConfigured: SQLite 3.9.0 or later is required (found 3.7.17)

when I run a command in terminal

python manage.py runserver 0.0.0.0:8000

how do I upgrade my SQLite version ??

Hopefully the package manager (is it yum?) would have a more recent version.

If not there are steps for manually building SQLite on the Wiki page for the setting up JSON1 Extension.

1 Like

thanks @ carltongibson for a quick reply Yes yum is my packet manager and my current SQLite version

3.7.17 

can I update my version without manually I am not familiar with most of Linux command

I’m afraid I don’t know my way around AWS Linux. You’ll need to Google yum a bit….